[NG] New certificate for idcheck.ariadnext.io

Incident Report for IDnow GmbH

Resolved

The security maintenance happened last week as detailed into https://status.idnow.de/incidents/nv2v36nqlry1.
Posted Oct 29, 2025 - 10:12 CET

Monitoring

Dear customers, to improve the security of our platform, we proceeded to a maintenance on 23/09/2025 notified by https://status.idnow.de/incidents/jy6mg384qdpc

The maintenance notification included the new IP address used by some services.

Depending on the security configuration of your own applications, you may have to add to your trust stores the new certificate chain used by those services. Please note this new certificate chain is in place in our testing environment (aka idcheck-sandbox) since 25/06/2025.

You can download it from your browser by connecting to https://customer-identity.idcheck.ariadnext.io/ .
Posted Sep 25, 2025 - 12:06 CEST
This incident affected: IDnow Solutions (IDCheck.io).