Service Disruption
Incident Report for IDnow GmbH
Postmortem

On Friday, 22nd of July, our system could not process idents for 1h 20min. This event was triggered by adding a high number of ident reviews to the queue. The performance of our database dropped as a consequence and triggered a chain reaction which made the system unavailable. We managed to recover the system to its previous state by removing some of the ident reviews from the queue. We continued processing the idents in batches.

Affected services: all

Customer Impact: Calls could not be placed.

We sincerely apologize for the trouble this has caused.
Your IDnow DevOps Team

Posted Jul 25, 2022 - 13:18 CEST

Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 15:05 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2022 - 13:28 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 22, 2022 - 13:18 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 22, 2022 - 13:17 CEST
Investigating
We are currently investigating this issue.
Posted Jul 22, 2022 - 11:58 CEST
This incident affected: Europe - IDnow (Video-Ident, eSigning QES, eSigning AES, Photo-Ident, API, AutoIdent).