[LEGACY][Check'nSign] System maintenance on advanced signature
Incident Report for IDnow GmbH
Resolved
We had an isue on Check'nsign between 3:34 p.m. and 3:44 p.m.
Posted Feb 13, 2024 - 15:46 CET
Update
We are continuing to investigate this issue.
Posted Feb 13, 2024 - 15:44 CET
Investigating
We have a service disruption on Check'nsign since 3:34 p.m.
Posted Feb 13, 2024 - 15:43 CET
This incident affected: IDnow Solutions (Check'nSign.io).