Experiencing issues with e-sign
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 17:34 CEST
Update
An incident is impacting several servers of protect and Sign platform . Some signatures are failing.
Posted Sep 16, 2021 - 16:48 CEST
Investigating
We are currently investigating this issue.
Posted Sep 16, 2021 - 16:44 CEST
This incident affected: IDnow Solutions (eSigning QES, eSigning AES).