Service Disruption for esign with QTSP

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted May 29, 2025 - 09:09 CEST

Monitoring

A fix has been implemented. Error rates are back to normal values. We will continue to monitor the situation.
Posted May 28, 2025 - 17:34 CEST

Update

We are continuing to investigate this issue.
Posted May 28, 2025 - 16:45 CEST

Investigating

We are experiencing higher than normal error rates in our signing service.

This only affects customers who use esign with IDnow QTSP.
Posted May 28, 2025 - 16:45 CEST
This incident affected: IDnow Solutions (VideoIdent, eID, AutoIdent, AutoIdent QES, eSign, InstantSign).