CLOSED: Swiss DataCenter - Intrum - eSigning - Partial Service Unavailability for Android
Incident Report for IDnow GmbH
Postmortem

We traced the problem back to an incompatibility between the backend of our eSigning service in Switzerland with a version of a library used by our Android app. This lead to a crash of the app when eSigning was tried in our Swiss data center. We are currently evaluating why exactly these version were incompatible and how we can prevent such an issue in the future.

We would like to apologize for any inconvience in our service.

Posted Oct 04, 2019 - 11:01 CEST

Resolved
The fix has been deployed at 18:00 and esigning are now working correctly again also for our Swiss customers.

Impact: eSignings in our Swiss data center could not be completed on Android devices
Posted Oct 03, 2019 - 20:23 CEST
Identified
We have identified an issue in our Android app. We are currently preparing the fix for the app and will deploy it as soon as possible.
Posted Oct 03, 2019 - 15:57 CEST
Investigating
Service Impact: We are investigating an issue that sometimes esignings can not be finished using Android devices. We are already in contact with our Swiss service partner for esigning for further analysis.

NOTE: This does not affect our German services or customer using iOS or web in the Swiss data center.
Posted Oct 03, 2019 - 13:09 CEST
This incident affected: Switzerland - Intrum (eSigning QES, eSigning AES).