Coronavirus (COVID-19) - Activation of extended security policy
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Oct 16, 2020 - 15:44 CEST
Monitoring
Dear Partners & Customers,

Our most important goal is to continue to provide you with optimum service during these challenging times, to ensure you are still able to offer business and banking processes without restrictions.

To this regard, our task force is evaluating the situation on a daily basis in order to initiate the appropriate measures. In view of the increasing restrictions on mobility due to government guidance, and taking into account the growing health risk to our employees, we are today assessing the situation further to ensure we are taking the necessary steps as a precautionary measure. This will ensure that we can continue to offer our services in an efficient and uninterrupted way.

Over the next few days, we will therefore begin to activate the security concept for remote working. This means that from 27.03.2020 12:00 the first identifications will be carried out remotely. These will be based on the Emergency Security Policy, Emergency Acceptable Use Policy certified by TÜV IT and the Technical and Organizational Measures.

Currently this applies only to a small part of our employees. We constantly review the situation so we can adjust the number of remote workers if necessary. Our goal is to keep this measure to a minimum. This enables us to continue to provide you and your end customers with a continuous service of the highest quality. With our concept, certified by TÜV IT, we ensure the processing of identification requests according to the highest security standards.

What does this mean exactly?

The first identifications are now performed - according to the specifications of the certified security concept - via remote work. At the same time, we are intensifying our monitoring, analysis and spot checks of the identifications to ensure the service quality you have come to expect from IDnow remains the same. In addition, all identifications carried out remotely are marked by us in order to ensure subsequent evaluation. In the future, we plan to provide this information in the result files and in our reports. During the time we transition agents to their remote working places we might see an impact on SLA. As soon as the transition if finished, SLA should normalize again.

We will of course continue to keep you proactively informed about our measures. We are doing everything in our power to maintain the best possible service in this exceptional pandemic situation.

For all questions please contact your account management representative.

Stay healthy!

Best regards,
Your IDnow Team
Posted Mar 27, 2020 - 14:16 CET
This incident affected: Ident Centers (Ident Center Munich) and IDnow Solutions (Video-Ident, eSigning QES, eSigning AES, AutoIdent).