High Volume
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 18:09 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2021 - 16:30 CET
Identified
We are currently experiencing an unexpectedly high volume of incoming ident requests. That leads to longer waiting times. We are increasing the capacity of Ident Experts with urgent priority. Thanks for your patience.
Posted Jan 04, 2021 - 15:00 CET