Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 23:00 CET
Update
Sorry for the inconvenience due to the short notice but this maintenance must happen as soon as possible to prevent an incident within the next couple of days.
Posted Mar 12, 2025 - 17:14 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 12, 2025 - 17:08 CET
Scheduled
Dear customer,
We would like to inform you that our system will undergo scheduled maintenance. During the maintenance period, we will update the configuration of a database and we will have to shut it down. Our dedicated team will be working diligently to minimize any downtime and complete the maintenance as quickly as possible.
We apologize for any inconvenience caused and appreciate your patience. If you have any questions or concerns, please get in touch with us using https://support.idnow.io
Sincerely Yours, IDnow DevOps Team
Posted Mar 12, 2025 - 17:05 CET
This scheduled maintenance affected: IDnow Solutions (IDCheck.io).