[Advanced Signature] Service Disruption

Incident Report for IDnow GmbH

Update

We are continuing to work on a fix for this issue.
Posted Aug 09, 2026 - 03:57 CEST

Identified

We are currently experiencing a service disruption on our advanced signature service
Our engineering teams are actively investigating the issue and working to restore full functionality as quickly as possible.
We appreciate your patience and will provide timely updates until the service is fully restored.
Posted Aug 09, 2026 - 03:16 CEST
This incident affects: IDnow Solutions (Check'nSign.io).