*.identity.tm subdomains unreachable due to DNS issue

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 11:46 CEST

Monitoring

DNS resolution seems to be functioning again. We are collecting evidence for investigation.
Posted Jul 27, 2026 - 11:34 CEST

Investigating

*.identity.tm domains (including dedicated status page) are not resolved by the DNS, resulting in lack of access to the systems.
Posted Jul 27, 2026 - 11:17 CEST