Service Disruption

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 16:53 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2025 - 16:42 CET

Investigating

We are currently experiencing a service disruption.
Our engineering teams are actively investigating the issue and working to restore full functionality as quickly as possible.
We appreciate your patience and will provide timely updates until the service is fully restored.
Posted Nov 10, 2025 - 16:29 CET
This incident affected: IDnow Solutions (VideoIdent, eID, AutoIdent, AutoIdent QES, POS, eSign, InstantSign, eSign Wallet).