Service disruption (Test Systems)
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 18:00 CEST
Investigating
We are currently investigating this issue.
Posted Aug 17, 2022 - 16:10 CEST
This incident affected: Test Systems.