[IDCheck.io/PVID/Check'n'Sign] Degraded Performance

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 17:19 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2026 - 17:14 CEST

Identified

We identified a performance downgrade from 16:08 till 17:00.
Posted Sep 16, 2026 - 17:07 CEST

Investigating

We're experiencing an performance degradation and are currently looking into the issue.
We will provide regular updates on the issue.
Posted Sep 16, 2026 - 16:56 CEST
This incident affected: IDnow Solutions (Check'nSign.io, IDCheck.io, IDCheck.io PVID).