Elevated API Errors
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 14:02 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2022 - 07:36 CEST
Update
Since Friday, we have continued to work on further network setup changes. As soon as the changes are deployed - knowing what we know now, it will be Wednesday - we will perform tests internally to reaffirm the fix of the issue. These changes shall not have any downtime, but please watch out for additional notifications on it. Rest assured, our teams are working continuously to take appropriate steps to remediate.
Posted Aug 08, 2022 - 17:06 CEST
Update
Last evening our data center provider upgraded the firmware on one of the central network load balancers, but we did not see any big improvement. During last day, we actively provided workarounds to many impacted customers, and many can continue to operate at normal levels.
As the situation stabilized, we will maintain this status during the weekend, and will not change or update systems.
Meanwhile, we are working with our data center provider, and execute additional changes on Monday onwards to resolve the issue.
These changes shall not have any downtime, but please watch out for additional notifications on it.
Posted Aug 05, 2022 - 11:40 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 04, 2022 - 15:01 CEST
Identified
We were able to reproduce the issue with our API and in order to fix it, our datacenter provider will upgrade the faulty load balancer today between 21:00 and 23:59 CET. The upgrade might cause disruptions in the traffic for 1 - 3 seconds.
Posted Aug 04, 2022 - 15:00 CEST
Update
During our investigations today we managed to narrow down the problem to one load balancer which is handling all the traffic coming from outside. Our datacenter provider will upgrade the load balancers as fast as possible in the coming 36 hours. In the meantime we are working with all of our customers who still experience the problem on implementing a temporary work-around.
Posted Aug 03, 2022 - 18:44 CEST
Update
We are working relentlessly with partners and consultants to solve the elevated api errors. With multiple trials, we could isolate the issue which at this moment, points to a load balancer with our data center provider and is used to receive traffic. While we continue to solve the issue completely, we have provided a workaround as a temporary solution for some affected customers, to be able to continue their daily Business. We are continuing to improve the situation and are taking appropriate steps to remediate. This issue is treated with highest priority and we will report with updates on status page regularly.
Posted Aug 03, 2022 - 16:39 CEST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2022 - 07:01 CEST
Update
Our investigation regarding the elevated API errors is still ongoing. Over the last days, we have tried many settings and have worked closely with some of affected customers, but it did not yield the desired results. Please rest assured that our teams keep working hard to identify the root cause and appropriate steps to remediate. Of course, this issue remains on highest priority and multiple stakeholders including our datacenter provider, our firewall provider and additional networking consultants work on a solution.
The next planned action is to change firewall and system settings at 6AM to assess if this will improve the situation. We will provide a next update soon after to the affected customers.
Posted Aug 02, 2022 - 19:02 CEST
Update
We are still investigating the API issues with our partners and are working on some potential fixes. The good news is that not all customers have been affected by this issue, but we would encourage customers to raise any similar issues with us via support channels. We, of course, are still treating this issue with the highest priority and will revert with an update as soon as we can.
Posted Aug 01, 2022 - 19:02 CEST
Update
We're aware of an issue that is currently causing failures of API calls. We are working along with our data center provider Noris to identify the cause and appropriate steps to remediate. We will update the status page again as soon as we have a solution.

Thank you for being patient.
IDnow DevOps team
Posted Jul 29, 2022 - 15:33 CEST
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Jul 29, 2022 - 10:53 CEST
This incident affected: Europe - IDnow (Video-Ident, eSigning QES, eSigning AES, Photo-Ident, API).