[NG][IDCheckIO] Service Disruption

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 12:07 CET

Identified

We are currently experiencing a service disruption on notifications

Our DevOps team is working to identify the root cause and implement a solution. IDCheckIO users may be affected.

We will send an additional update in 30 minutes.
Posted Mar 19, 2025 - 10:09 CET
This incident affected: IDnow Solutions (IDCheck.io).