[TEST System] Degraded Performance

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Sep 25, 2026 - 12:49 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2026 - 12:31 CEST

Investigating

We are currently experiencing a degradation in performance on our TEST system and our team is actively investigating the root cause.
We appreciate your patience and will post regular updates until service performance returns to normal.
Posted Sep 25, 2026 - 10:33 CEST
This incident affected: Test Systems (VideoIdent, AutoIdent, AutoIdent QES, eSign).