[Legacy] Service Disruption

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 14:23 CEST

Monitoring

Check'n'Sign access has been restored. We are monitoring closely.
Posted Jul 08, 2025 - 11:04 CEST

Investigating

We are resuming investigation to fix the access to Check'n'Sign via Legacy endpoint.
Posted Jul 08, 2025 - 08:53 CEST

Update

Smartstamp is fully operational.

Check'n'Sign access through Legacy is still broken. We will resume the investigation first hour tomorrow morning.
Posted Jul 07, 2025 - 18:06 CEST

Update

Actually the access to Check'n'Sign is still broken. This is under investigation.
Posted Jul 07, 2025 - 16:39 CEST

Monitoring

The access to Check'n'Sign Legacy has been restored. We are verifying the end to end tests are executed successfully.
Posted Jul 07, 2025 - 16:34 CEST

Update

The incoming access to Smartstamp has been restored. We are now working on restoring the outgoing access.
Posted Jul 07, 2025 - 15:54 CEST

Identified

The team is working on restoring the access to Smartstamp by the end of the day today.
Posted Jul 07, 2025 - 15:35 CEST

Investigating

We are currently experiencing a service disruption on Legacy.

Our DevOps team is working to identify the root cause and implement a solution. Smartstamp users may be affected. Check'n'Sign clients which have not been migrated to NG are also impacted.

We will send an additional update in 60 minutes.
Posted Jul 07, 2025 - 14:20 CEST
This incident affected: IDnow Solutions (Check'nSign.io, SmartStamp).