Service Disruption

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 17:12 CEST

Investigating

We are currently experiencing a service disruption.
Our engineering teams are actively investigating the issue and working to restore full functionality as quickly as possible.
We appreciate your patience and will provide timely updates until the service is fully restored.
Posted Jul 20, 2026 - 16:25 CEST
This incident affected: Ident Centers (Ident Center Iasi).