Degraded Performance of eSign with QTSP

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 08:07 CEST

Monitoring

We experienced a service disruption with our signing service.

Our team is working to identify the root cause and implement a solution. Customers who use esign with IDnow QTSP are affected.

The issue has been resolved by 10:30 CEST.
Posted Jun 02, 2025 - 10:54 CEST
This incident affected: IDnow Solutions (AutoIdent QES, eSign).