[NG] Service Performance Degradation

Incident Report for IDnow GmbH

Resolved

The incident has been resolved. We keep the platform under close monitoring.
Posted Mar 28, 2025 - 12:57 CET

Monitoring

The service is back to stable.
Posted Mar 28, 2025 - 12:52 CET

Identified

We identified the root cause. We are applying a patch.
Posted Mar 28, 2025 - 12:47 CET

Investigating

We are currently experiencing a service performance degradation on NG.

Our DevOps team is working to identify the root cause and implement a solution.

We will send an additional update in 60 minutes.
Posted Mar 28, 2025 - 12:33 CET
This incident affected: IDnow Solutions (Check'nSign.io, IDCheck.io).