Call center performance Degradation
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 21:36 CET
Investigating
We're experiencing a performance degradation and are currently looking into the issue. Call processing times might be longer than usual.
We will provide regular updates on the issue.
Posted Jan 31, 2024 - 20:58 CET
This incident affected: IDnow Solutions (Video-Ident, eSigning QES, eSigning AES) and Ident Centers (Ident Center Berlin, Ident Center Split, Ident Center Timisoara, Ident Center Varna, Ident Center Zagreb I, Ident Center Zagreb II, Ident Center Sarajevo).