Degraded Performance

Incident Report for IDnow GmbH

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 02:47 CEST

Investigating

We're experiencing a performance degradation and are currently looking into the problem.
We will provide regular updates on the issue.
Posted Jun 23, 2025 - 01:01 CEST
This incident affected: IDnow Solutions (VideoIdent, eID, AutoIdent, AutoIdent QES, POS, eSign, InstantSign, eSign Wallet).