Our service hours on holidays
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Jan 16, 2023 - 12:03 CET
Investigating
Dear clients,

please note, our service hours for VideoIdent will be different than usual on the following holidays:

24th December 2022: 8 am to 4 pm
31st December 2022: 8 am to 4 pm
1st January 2023: 2 pm to 12 am
*If you would like to benefit from extended service hours for VideoIdent, ask your account manager about our 24/7 service.

For AutoIdent: (incl. AI GwG and AI AML): No time-off. We will provide a 24/7 service throughout Christmas and New Year’s.

On all other days we are available at the usual times.

We wish you happy holidays and a good start into the new year.

Best regards,
Your IDnow Team
Posted Nov 28, 2022 - 16:12 CET