Service Disruption
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 18:03 CEST
Investigating
We are currently experiencing a service disruption.

Our DevOps team is working to identify the root cause and implement a solution.

We will send an additional update in 60 minutes.
Posted Oct 14, 2021 - 16:45 CEST