Switzerland - Ident Center - Service Disruption
Incident Report for IDnow GmbH
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 11:42 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2019 - 10:55 CEST
Investigating
We are currently experiencing a service disruption on our Swiss CallCenter.

All users may be affected.

We will send an additional update in 60 minutes.
Posted Oct 22, 2019 - 08:43 CEST
This incident affected: Ident Centers (Ident Center Zürich).